CREATING DIGITAL EDITIONS: AN INTRODUCTION TO THE TEXT ENCODING INITIATIVE (TEI)
http://www.lib.umich.edu/publishing-production/creating-digital-editions-introduction-text-encoding-initiative-tei
Exercise: TEI encoding 2
This exercise is based on one used as part of “From Text Encoding to Digital Publishing”, a two-day workshop held at the National University of Ireland, Galway, and sponsored by the Digital Humanities Observatory, a project of the Royal Irish Academy.
The previous exercise gave an opportunity to encode a text whose structure is quite clear to the contemporary reader and to experiment with rendering this text in a web browser and in PDF format. In this exercise, we will work with an older text whose structure is less apparent at first glance: two facing pages of the beginning of a chapter of Vegetable Dyes from North American Plants.
The exercise assumes that you have a working installation of <oXygen/> XML Editor version 12 or later as well as the following files:
· Recipes_32-35.pdf
· recipes.win.txt
· recipes.mac.txt
· recipes-metadata.txt
You might want to work with a printout of recipes.pdf (which is two pages when printed on Letter size paper) rather than viewing it on your computer.
Part A: Getting started
1. Open the <oXygen/> (with a blue icon, not the “author” mode with a red icon).
2. Go to File → New…
3. In the hierarchy, click the Framework templates folder and then the TEI P5 folder.
4. Choose TEI Lite to create a document using the latest version of TEI Lite with the minimum tags required to be valid and some boilerplate text filled in to guide you.
5. Go to File → Save As… to save the document. Save it as recipes.xml in the documents directory along with the other XML documents.
You might notice that the lines before the TEI element look different from how they appeared in the previous exercise.
After the XML declaration (whose presence is recommended as the first line of any XML file):
<?xml version=”1.0” encoding=”UTF-8”?>
you’ll find a processing instruction for <oXygen/> that gives the location of the schema. It contains an absolute URL (to a version online) in this exercise, whereas in the previous exercise it contained a relative path to a file on your hard drive. Both ways are possible. In fact, <oXygen/> recognizes TEI documents and is able to validate even without an Internet connection using its own copy of the TEI Lite schema.
Let’s add an “ID” to the root element:
6. Place your cursor after xmlns="http://www.tei-c.org/ns/1.0" but before the closing angle bracket (>).
7. Press the spacebar. A list of allowed attributes will appear.
8. Choose xml:id and give it the value recipes.
Check that the document validates:
9. Choose Document → Validate → Validate. There’s also a button for this in the toolbar that looks like this: [image: Macintosh HD:Users:matthewzimmerman:Desktop:Picture 1.png]. If your document is not valid, error messages will appear at the bottom of the <oXygen/> window, and the invalid sections of the document will be underlined with a red squiggly line.
10. To make the document easier to read, choose Document → Source → Format and Indent. There’s also a button for this in the toolbar that looks like this: [image: pretty-print].
We’ll start with the body of the source document (which will be represented within the text element) and do the metadata (which will be represented in the teiHeader element, above the text element) last.
Part B: Encoding the body of the document
In addition to the scanned page images of the text (recipes.pdf) to be encoded, we’ve also provided a plain-text transcription of the text so that you can copy and paste into your TEI document rather than typing everything yourself.
The file uses tabs and line breaks to approximately the layout of the text on the printed page, but as we learned in the previous exercise, this whitespace is ignored in XML. We will be using XML tags in order to make this structure explicit without relying on whitespace in the digital document to convey this structure. Likewise, plain text does not preserve any font effects (small caps or italics), but these can also be encoded using XML.
1. Open recipes.win.txt or recipes.mac.txt (depending on whether you’re using Windows or Mac OS X) in <oXygen/>. This should now be your second document open within <oXygen/>; you can switch between the two files using the tabs:
[image: ]
You might also choose to view the files side by side: choose Window → Tile Editors Vertically. To switch back, choose Window → Stack Editors.
The body of the TEI document has some fake content which we’ll need to replace with the real content of our text:
2. Replace the “Some text here” paragraph and the figure element with opening and closing div tags, which indicate a structural division of text.
3. Add a type attribute with the value chapter to the div element. Remember that attributes and attribute values go on the opening tag, not the closing one: 
<div type="chapter"></div>
The TEI allows you to use any value for the type attribute. A project should develop a controlled vocabulary of values to ensure consistency of encoding practice within and across XML documents.
Within this div that we’ve just inserted, we will insert the content of this chapter (up to the end of page 33).
4. Within the div tags, insert a head element and put the name of the chapter between the opening and closing tags.
5. Following the head, insert a p element for the text of the first paragraph (and insert the text of the paragraph there).
6. Now’s a good time to save and validate.
After this paragraph are two recipes. Each has a heading of its own. Headings are a good indication that a new section of a text begins.
7. After the p element, insert two div elements—one for each recipe—each with type="recipe". Don’t copy and paste the plain text in quite yet.
The body of your TEI document should now look like this:
[image: ]
You’ll see that you have two recipe “divs” within the main chapter “div”.
The first recipe contains a table with four rows and two columns. Look at what follows this: it appears to be a paragraph with three sentences, but these sentences are actually steps in the recipe. In fact, if you look at the second recipe, you will see that it consists of only steps, which are not fully justified (with a smooth right edge) but instead are typeset so that no step is broken across lines. So while the typesetter of this book was inconsistent in the style used for the steps in the first and second recipes, we will encode both sets of steps using the same XML tags. That way, in our new digital edition of this work, we can ensure that steps are always displayed uniformly. (TEI has rich mechanisms for capturing the imperfect appearance of the source document, but in this case we’ll just capture the underlying structure of the text.
8. For the first recipe:
a. Insert a head for the title of the recipe.
b. Following the head element, insert a table element.
c. Fill out the first table—four row elements, each containing two cell elements.
d. Encode the list of three steps in the first recipe using the list element. Each step should be in an item element within the list.
9. Now would be a good time to use Format and Indent and then Validate. Note that if you run Format and Indent when there is a pair of opening and closing tags with no content (like <div type=”recipe”></div>), it will collapse these tags into a single empty element: <div type=”recipe”/>.You will need to “uncollapse” the <div type=”recipe”/> in order to add content to this element in the next step.
10. Within the div for the second recipe:
a. Insert a head for the title of the recipe
b. Insert a list for the steps of the recipe.
The hierarchy of tags should now look like this (with lower levels of the hierarchy omitted for brevity):
[image: ]
At the top of page 33, we see a heading.  While this might at first look like a running header including the title or author, appearing at the top of each right-facing page, you’ll see that it doesn’t appear on page 35. Therefore, it’s clearly a heading introducing a section on the alder shrub. So now we realize that everything in this chapter up to this point is itself a sort of introductory section, albeit without a heading such as “Introduction” labeling it explicitly. Instead of simply adding another “div” as a sibling of the two recipe “divs”, we should instead group together all of the introductory text in a “div” at a level between the chapter and the recipe. That is, we now see that the section beginning “Alder” is at a higher level in the hierarchy than the two recipes we identified.
11. Wrap the p and the two instances of <div type="recipe">—but not the chapter title—within a <div type="intro">.  Your hierarchy will now look like this:
[image: ]
12. Take a moment to Format and Indent and look at the structure of the document.  Note that all of the div elements contain a head except one—the introduction that isn’t labeled in the source document as being an introduction.
13. Following the closing tag of the <div type="intro">, insert a <div type=”plant”>. This new “div” will be a sibling, not a child, of the intro “div”.
14. Inside the new div, insert a head for the text at the top of page 33.
Here’s the hierarchy now:
[image: ]
What should we do with the italicized text in this heading? While TEI has an element (hi) for indicating that text is highlighted without saying why it’s highlighted, it would be more in keeping with the spirit of XML to describe its structure. Why is this text italicized? The first word looks like a Latin name for the plant, so we can label this word as such. In fact, the first word—in all caps—is also a name. We can use the name element to tag text as containing a name, and we can use the xml:lang attribute to indicate the language of that name. But what is “Aune”?  If you look at the later pages, you see that names in parentheses are French names for plants. You can also use the xml:lang attribute to label this as being in French.
Since in our edition of this classic work, we want to make sure users can search on any name of a plant that they might know.  So we should carefully encode names.
15. Wrap “ALDER” in <name xml:lang="en">. 
16. Wrap “Alnus” in <name xml:lang="la">.
17. Wrap “Aune” <name xml:lang="fr">.
According to the TEI Guidelines, the value for the xml:lang attribute must follow the a standard called BCP 47. For now, just take our word for it that according to this standard, these are the codes for English, Latin, and French.
Should the parentheses really remain outside of the name element?  How should you encode a name in a possessive form (with an apostrophe and an s)?  People’s opinions on questions like this vary, and it really depends on what you want to do with the text afterwards.  Since names in English don’t change much (just possessive and sometimes plural forms), one advantage of leaving the parentheses (and possessive tagging) outside of the tags is that it’s easy to write a program to pull all the names of out of the document without needing to worry about stripping this stuff from the name afterwards.
18. Continue encoding the text on page 33.  Here are some elements that will be useful:
a. name not just for the names of plants but als the names of places and peoples
b. cit for a quotation from an outside work, which can contain:
i. quote for the quotation itself
ii. bibl for the bibliographic citation. Use <oXygen/> to find elements allowed as children of bibl which will be helpful in encoding the components of the citation.
Note that the cit element may only contain child elements, not any text content. For that reason, you will need to include the dash before the bibliographic citation in either the quote or the bibl element.
Be sure to read the recipe closely to distinguish prose from the list of steps!
Near the bottom of page 33 you will see a heading the beginning of a new section, labeled “Brown. Alder Roots, 1 lb.”  Where should this fit in the hierarchies of div elements? Is it a sibling or child of “ALDER. Alnus (Aune)”? If you look at the following page, you will see that it is a heading for the first of three brief recipes within the section on alder.  Therefore, you should make it a child of the “ALDER” div.
19. Encode the alder roots recipe in a child div.
We won’t bother including the page number in the encoded text. Running headers, running footers, and page numbers are all called forme work and are rarely encoded because they can be automatically generated later. However, if you were encoding a significant edition of a work and wanted to represent the text of the edition as it is, even with errors, you might want to encode the forme work.
* * *
Let’s look at page 34 and discuss how we would encode the components of this page if we had time. We see two more recipes in the alder section: one for “yellow-green” and another for “yellow-brown”. These would each be in a div that is a sibling of the div for the “alder roots” recipe you last encoded. Then the parent div for “ALDER” ends.
Note that the “yellow-brown” recipe is not indented like the previous two.  This appears to be a mistake in the typesetting of this book, not something significant about the structure of the text. Therefore, you might choose to ignore this when encoding the text. On the other hand, if such typesetting mistakes are of historical interest, you might want to represent these variations using the TEI’s rend attribute, which is used for describing the rendering of the text in the source document.
Following this recipe, you see a heading for “APPLE” and later one for “BEARBERRY”. These are both centered and are followed by the Latin and French names for the plant. For “BEAERBERRY”, the Latin and French names are on their own lines, but this appears to be simply because there wasn’t enough room to fit them on one line, as with “ALDER” and “APPLE”. This is an “artifact of printing”, similar to the case of a word hyphenated across lines, that is generally not represented in the encoded in the text.
Part C: Filling out the header
A catalog record for this book is available at the URL given in recipes-metadata.txt. Open this webpage to get the information that you’ll copy and paste into the teiHeader.
You’ll recall from when we learned about the header earlier that there is a separate place in the header for describing the digital text and for the source from which this digital text was created:
[image: ]
The fileDesc in <oXygen/>’s template contains only a titleStmt and a sourceDesc (since these are the only child elements required for fileDesc). Let’s first fill out the sourceDesc using the information from the catalog record. The sourceDesc can contain either a free-text prose description in a p element or a more structured description using nested elements.  For this exercise, we’ll use bibl for a structured citation.
1. Replace the p and its boilerplate text with the author, title, pubPlace, publisher, and date elements (which can occur in any order) with the appropriate text from the catalog record in each. Some notes about how to read a catalog record:
a. Cataloging convention is to capital the initial word in a title and proper nouns, not most words in a title as in English. Feel free to preserve this practice or capitalize words to look more like a title typically does in English.
b. The catalog record gives two dates: 1969 and 1943.  1969 is the date that this edition was published, whereas 1943 is the copyright date included on the title page verso. Just include 1969 within imprint.
Next we’ll describe our digital edition of this work using the other child elements of fileDesc.
First we’ll fill out the titleStmt with the following child elements:
2. Replace the content of the title element with an appropriate title for your digital edition—perhaps something like “A digital edition of an excerpt from Vegetable dyes from North American plants”.  So we will have a title within a title. You can do this in TEI!
3. Insert an author element for the author of the digital document. (The author of the digital document is the same as the author of the source document.)
4. Insert an editor element for the editor of the digital document (you!).
The publicationStmt element contains information about the publication of the digital text. Like the sourceDesc, allows either unstructured content in a p element or structured content using other elements.
5. Inside the publicationStmt, replace the content of the p element with structured elements to indicate that this digital text will be deposited in Deep Blue, the institutional repository of the University of Michigan, in 2011.
Congratulations! You’ve finished the exercise. If you still have time left and have also finished the previous exercise, look at the source document to see if there are other elements of the document you might want to encode and what utility this tagging that would provide for you.
1

image4.png
<body>
<div type="chaprar>
<head>RECIPES</head>
<p>IN the Tollowing recipes, it is understood that
the standard methods discussed in previous pages
are the be used, unless some variation from this
nethod is given. Tt should be noted that there
nay be differences in the mordanting as well as
in the dyeing. The standard methods for these
a0 procasses are repeatad in brief form hers.</p>
<div type="recipe!
<div tp:
</div>
</body>





image5.png
9 @ body
? @ div chapter’ RECIPES
© head RECIPES
©p INthe following recipes, itis
7 @ divrecipe’ STANDARD MORDANTING RECIPE
@ head STANDARD MORDANTING RECIPE
o @ table
o o list
? @ divrecipe’ STANDARD DYEING RECIPE
© head STANDARD DYEING RECIPE
o @ list




image6.png
9 @ body
? @ div chapter’ RECIPES
© head RECIPES
7 @ divintro" IN the following recipes, it is
©p INthe following recipes, it is
7 @ divrecipe’ STANDARD MORDANTING RECIPE
@ head STANDARD MORDANTING RECIPE
o @ table
o o list
? @ divrecipe’ STANDARD DYEING RECIPE
© head STANDARD DYEING RECIPE
o o list




image7.png
‘chapter’ RECIPES
© head RECIPES
7 @ divintro" IN the following recipes, it is
©p INthe following recipes, it is
o @ div "recipe’ STANDARD MORDANTING RECIPE
o @ div "recipe’ STANDARD DYEING RECIPE
? @ div'plant’ ALDER. Alnus (Aune)
© head ALDER. Alnus (Aune)




image8.png
1. <filedesc>: bibliographic info (required)
1 <titleStmt> (required)
2. <editionStmt> (optional) All other elements describe
3. <extent>(optional) the TEI document itself.
4. <publicationStmt> (required)
5. <seriesStmt> (optional)
6.  <notesStmt> (optional)
2
2. <encodingDesc>: description of encoding practices (optional)
3. <profileDesc>: search terms (optional)

4.  <revisionDesc>: record of changes (optional)




image1.png




image2.png




image3.png
o recipes.xml_x e recipes.mactxt





